ANALYSIS OF A PLATE WITH STRESS CONCENTRATIONS

Instructor: Professor James Sherwood
Revised: Jacob Wardell, Dimitri Soteropoulos
Programs Utilized: HyperMesh Desktop v12.0, OptiStruct, HyperView

Problem Description:
This tutorial illustrates the effects of various stress concentrations on a plate. Three different stress concentrations are incorporated into the geometry of an aluminum plate: a hole, fillets, and a crack. The mesh of the plate is designed and refined to fit the conditions of the geometry.

Step 1: Open HyperMesh

1. Open HyperMesh
2. (If it doesn’t pop up automatically at start up) *From the pull-down menu toolbar at the top of the screen, click on Preferences, then select User Profiles from the pull-down menu.
3. Select OptiStruct:

4. Click OK.
Once the **User Profiles** pop-up window is exited, the HyperMesh interface should look similar to the image below. (Please note the **Model Browser** is the area on the left hand side of the viewport, while the **menu bar** is at the top of the window, right below the title bar)
Step 2: Create a material

1. Access the *Create material* panel one of the following ways:
   - From the menu bar, choose *Materials > Create.*
   - Right click in the *Model* browser and click *Create > Material.*

2. Click the *Name:* field and enter “Aluminum”
3. Click the square *color* icon and choose a color (besides gray).
4. Make sure that the *Card image:* is set to MAT1.
5. Make sure that the box to the left of the text “Card edit material on creation” is checked.
6. Make sure that the box to the left of the text “Close dialog upon creation” is checked.
   *Make sure that the settings are the same as the ones shown below:

7. Click *Create.*
8. The *card edit* panel for the material will appear (with “MAT1” to the left of it).
9. Left-click on the \[ E \] in the card edit panel (*It will be gray until it is selected).

10. For the value of \[ E \], enter: \( 1 \times 10^7 \) (10 x 10^6) psi.
    *Please note there is no dropdown menu or feature in HyperMesh that sets specific units. All of the dimensions have been input in inches; therefore the respective Young’s Modulus (“E”) units should be entered in Psi (Pounds per square inch). The units chosen for the definition of the material properties should be consistent and dictate what units should be used for the dimensions of the structure.

11. Click on the \[ NU \] in the card edit panel (*It will be gray until it is selected).

12. Make sure that the value of \[ NU \] is 0.300 (so that the Poisson’s Ratio of the material is 0.3).
    *Make sure that the settings are the same as the ones shown below:

<table>
<thead>
<tr>
<th>MAT 1</th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>E</td>
<td>G</td>
<td>NU</td>
<td>rho</td>
<td>a</td>
<td>tref</td>
<td>ge</td>
</tr>
<tr>
<td></td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>300</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>( 1 \times 10^7 )</td>
</tr>
<tr>
<td>NU</td>
<td>0.300</td>
</tr>
</tbody>
</table>

13. Click the red return button on the bottom-right of the panel below. This will create a material titled “Aluminum”.

**Step 3: Create a property.**

1. Access the Component Collector panel one of the following ways:
   - From the menu bar, choose Properties > Create > Property.
   - Right click in the Model Browser and click Create > Property.

2. Click the Name: field and enter “pshell_prop”.

3. To the right of “Card image:”, select PSHELL:

4. Click the square color icon and choose a color.

5. Click on the Material tab.

6. Select Assign material.

7. To the right of “Name:” select Aluminum.
8. Make sure that the box to the left of the text “Card edit material on creation” is checked.
9. Make sure that the box to the left of the text “Close dialog upon creation” is checked.
   *Make sure that the settings are the same as the ones shown below:

10. Click Create.
11. The card edit panel for the material will appear (with “PSHELL” to the left of it).
12. Left-click on the $T$ in the card edit panel (*It will be gray until it is selected).
13. For the value of $T$, enter: 0.25. This will set the Thickness of the material to be 0.25 in.
   *Make sure that the settings are the same as the ones shown below:

   ![Card edit panel](image)

<table>
<thead>
<tr>
<th>P SHELL</th>
<th>FID</th>
<th>MEDI</th>
<th>$T$</th>
<th>MEDI</th>
<th>$T12,T3$</th>
<th>MEDI</th>
<th>$T5,T1$</th>
<th>NSM</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
<td>1</td>
<td>0.25</td>
<td>1</td>
<td></td>
<td>1</td>
<td></td>
<td>0.000</td>
</tr>
</tbody>
</table>

14. Click the red return button on the bottom right of the panel below.
   This will create a property titled “pshell_prop” with a thickness of 0.25 in.

**Step 3: Create a component to hold the model’s geometry.**

1. Access the Component Collector panel one of the following ways:
   - From the menu bar, choose Collectors > Create > Components.
   - Right click in the Model Browser and click Create > Component.
2. Click the Name: field and enter “Plate”.
3. Click the square color icon and choose a color.
*Make sure that the settings are the same as the ones shown below:

4. Click on the **Property** tab.
5. Make sure “**Assign property:**” is checked.
6. To the right of “**Name:**” select *pshell_prop*.
   *Make sure that the settings are the same as the ones shown below:

7. Click on the **Material** tab.
8. Make sure “**Assign material:**” is checked.
9. To the right of “**Name:**” select *Aluminum*.
10. Make sure that the box to the left of the text “**Close dialog upon creation**” is checked.
*Make sure that the settings are the same as the ones shown below:

11. Click **Create**.
12. This will create a new component titled “Plate” with the assigned material “Aluminum” and assigned property “pshell_prop”.

*The message “Component created” should appear in the status bar.*

*Left-click once anywhere in the HyperMesh window (except on a button) to dismiss the message in the status bar.*

*Left click on the “+” to the left of Component (1) in the Model tab.*

*The component called “Plate” is the current component and is bold in the Model Browser.*
Step 4: Create nodes

1. Create nodes one of the following ways:

   - From the menu bar, choose **Geometry > Create > Nodes > XYZ**
     
     ![Geometry Menu Screenshot](image)

   - Select from the **Geom panel**:
     
     1) Make sure the **Geom panel** is selected

     | nodes          | lines      | surfaces   | solids   | quick edit |
     |----------------|------------|------------|----------|------------|
     | node edit      | line edit  | surface edit | solid edit | quick edit |
     | temp nodes     | length     | defeature  | index edit | paint edit |
     | distance       | midsurface | dimensioning | 3D        | 3D         |
     | points         | dimensioning | 3D        | 3D         | 3D         |

     2) Click **nodes**

     | nodes          | lines      | surfaces   | solids   | quick edit |
     |----------------|------------|------------|----------|------------|
     | node edit      | line edit  | surface edit | solid edit | quick edit |
     | temp nodes     | length     | defeature  | index edit | paint edit |
     | distance       | midsurface | dimensioning | 3D        | 3D         |
     | points         | dimensioning | 3D        | 3D         | 3D         |

     3) Make sure that the **XYZ** icon is selected:

     ![XYZ Icon Screenshot](image)

2. Enter the X, Y, & Z coordinates of the points listed in Table 1. After entering the X, Y, & Z coordinates for each point, click **create** to create a node at that point:

   ![Node Creation Screenshot](image)
### Table 1. Points for Geometry

<table>
<thead>
<tr>
<th>Point</th>
<th>X Coordinate</th>
<th>Y Coordinate</th>
<th>Z Coordinate</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>-2.5</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>1.25</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>1.5</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>1.5</td>
<td>0.5</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>2.5</td>
<td>0.5</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>2.5</td>
<td>-0.5</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>1.5</td>
<td>-0.5</td>
<td>0</td>
</tr>
<tr>
<td>8</td>
<td>1.5</td>
<td>-0.75</td>
<td>0</td>
</tr>
<tr>
<td>9</td>
<td>1.25</td>
<td>-0.75</td>
<td>0</td>
</tr>
<tr>
<td>10</td>
<td>-2.5</td>
<td>-0.75</td>
<td>0</td>
</tr>
<tr>
<td>11</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>12</td>
<td>-2.0</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>13</td>
<td>-1.5</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>14</td>
<td>-0.75</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>15</td>
<td>0.75</td>
<td>0.75</td>
<td>0</td>
</tr>
<tr>
<td>16</td>
<td>0.75</td>
<td>-0.75</td>
<td>0</td>
</tr>
<tr>
<td>17</td>
<td>-0.75</td>
<td>-0.75</td>
<td>0</td>
</tr>
<tr>
<td>18</td>
<td>-1.5</td>
<td>-0.75</td>
<td>0</td>
</tr>
<tr>
<td>19</td>
<td>-2.0</td>
<td>-0.75</td>
<td>0</td>
</tr>
<tr>
<td>20</td>
<td>-0.25</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>21</td>
<td>0.25</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>22</td>
<td>-2.0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>23</td>
<td>-1.5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>24</td>
<td>-0.75</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>25</td>
<td>0.75</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>26</td>
<td>1.5</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

3. Once finished, click `return`.
Step 5: Display the node numbers.

1. Make sure the view is in the standard XY view by clicking on the “XY Top Plane View” icon near the top of the HyperMesh window.

2. From the menu bar, choose Geometry > Check > Nodes > Numbers.

3. Click on the highlighted nodes button and then click on displayed.

4. Click on the green “on” button (on the right side). This will display the node numbers:

5. Click return.
Step 6: Create two arcs

1. Access the Arc Center and Radius panel one of the following ways:
   • From the menu bar, choose Geometry > Create > Lines > Arc Center and Radius.
   • Select the Geom panel, click Lines, then select the Arc Center and Radius icon.

   (If necessary, click on the small black triangle to the right of the current “arc” creation icon
to select it from a list of options)

2. With node list selected, click on node 3 (1.5, 0.75, 0) shown below:

3. Make sure that the selection (in the middle of the panel) is set to “N1,N2,N3” option –
   *It may be necessary to click on the button to the left of it ( ▼ ) to set the selection to “N1,N2,N3”.

4. Select the green N1 button, then select node 2 (1.25, 0.75, 0) shown below

5. With the blue N2 button highlighted, select node 3 (1.5, 0.75, 0) shown previously.
6. With the red **N3** button highlighted, select node 4 \((1.5, 0.5, 0)\) shown below:

7. The value for **Radius** should be 0.250.

8. Enter -90 for “**Angle**:”.

9. Click **create**.

10. This will create an arc just like the one shown below:

11. Clear the **node list** selection by clicking on the icon to the right of the **node list** button.

12. With **node list** selected, click on node 8 \((1.5, -0.75, 0)\) shown below:

13. Clear the **N1,N2,N3** selection by clicking on the icon to the right of the **N3** button.
14. With the \textbf{N1} button selected, select node 7 (1.5, -0.5, 0) shown below:

15. With the blue \textbf{N2} button highlighted, select node 8 (1.5, -0.75, 0) shown previously.
16. With the red \textbf{N3} button highlighted, select node 9 (1.25, -0.75, 0) shown below:

17. The value for \textit{Radius} should be 0.250.
18. Enter 90 for \textit{Angle:}
19. Click \textit{create}.
20. This will create an arc just like the one shown below:

21. Click \textit{return}.
Step 7: Create straight lines

1. Access the Linear Nodes panel one of the following ways:
   • From the menu bar, choose Geometry > Create > Lines > Linear Nodes.
   • Select the Geom panel, click Lines, then select the Linear Nodes icon:

   (If necessary, click on the small black triangle to the right of the current “line” creation icon to select it from a list of options)

2. Make sure that the "Closed line" option is unchecked.
3. With node list selected, click on node 1 (-2.5, 0.75, 0) and node 12 (-2, 0.75, 0) shown below:

4. Click create.
5. This will create a line going from node 1 to node 12.

6. Repeat this process to create straight lines using the following nodes:
   • 12 & 13
   • 13 & 14
   • 14 & 15
   • 15 & 2
   • 4 & 5
   • 5 & 6
   • 6 & 7
   • 9 & 16
   • 16 & 17
   • 17 & 18
   • 18 & 19
   • 19 & 10
   • 10 & 1
Once completed, the created lines should look like the ones shown below:

Step 8: Create a circle

1. Access the Circle Center and Radius panel one of the following ways:
   - From the menu bar, choose Geometry > Create > Lines > Circle Nodes and Vector.
   - Select the Geom panel, click Lines, then select the Circle Nodes and Vector icon.

2. With node list selected, click on nodes 20 (-0.25, 0, 0) and 21 (0.25, 0, 0) shown below:

3. Make sure that the option in the center of the panel is set to z-axis.
   *If it is not set to the z-axis, click on the black downward arrow to the left of the selected option and select z-axis.
4. Click on the purple **B** button (to the right of the “z-axis” button) and click on node 11 (0,0,0) shown below:

5. Make sure that the value for “Offset:” is set to 0.000.
6. Click **create**. This creates a circle that is perpendicular to the z-axis and connected to nodes 20 & 21 (with a radius of 0.25 and center at node 11).
7. Click **return**.

**Step 9: Create additional lines**

1. Repeat Step 7 to create straight lines at the following locations: (lines between 2&3, 3&4, 7&8, and between 8&9, resulting in the image shown below:
Step 10: Create a surface

1. Access the Spline/Filler surface creation panel one of the following ways:
   • From the menu bar, choose Geometry > Create > Surfaces > Spline/Filler.
   • Select the Geom panel, click surfaces, then select the Spline/Filler icon:

2. Make sure that the highlighted selector option button on the left is set to lines.
   *If it is not set to lines, click on the black downward arrow to the left of the selected option and select lines.

3. Click on the lines highlighted selector option

4. Hold down the shift key on the keyboard, then hold down the left mouse button, dragging the mouse cursor over all of the nodes (forming a selection rectangle around all of the lines). This selects all of the lines within the rectangle.

5. Right click the two arcs that were created in Step 6. This deselects the arcs. The display should look like the image below:

6. Make sure that Auto create (free edges only) is disabled.

7. Click create.
Step 11: Trim the corners

1. Access the **Trim with Lines** surface edit panel one of the following ways:
   - From the menu bar, choose **Geometry > Edit > Surfaces > Trim with Lines**
   - Select the **Geom** panel, click **surface edit**, then select the **trim with lines** menu.

2. Click the **surfs** selector button in the middle column (just below “with lines”) and select all (It may be necessary to click the **surfs** button in order to pull up the option to select **all**).
3. Click the **lines** selector button in the middle column (just below the “**surfs**” selector button), then click on the two curves created in Step 6 (curves touching nodes 2 & 4 and nodes 7 & 9).
   
   • *If it is hard to see the arc lines, simply click on the **Wireframe Geometry** icon:*

4. Make sure that the plane selector (just below the **entire surface** button, with a black upside down triangle to the left of it) is set to **z-axis**. Click **trim**. This trims the surface along the curves selected.

5. Click **return**.

**Step 12: Delete the corners**

1. Click on the **Shaded Geometry and Surface Edges** icon:

2. Access the **delete surfaces** panel one of the following ways:
   
   • From the menu bar, choose **Geometry > Delete > Surfaces**.
   
   • Press the **F2** key on the keyboard and change the selector button (by clicking on the black upside down triangle to the left of the button) to **surfs**.

3. Click on the two corners that were just created in Step 11 by trimming the original surface. The display should look like the picture below:
4. Click the green *delete entity* button on the right side of the panel. This deletes the selected surfaces. The surface should now look something like the picture below:

5. Click *return*. 
Step 13: Trim the Surface with Nodes

1. (If it is not still displayed, access the Trim with Nodes surface edit panel)
   - From the menu bar, choose Geometry > Edit > Surfaces > Trim with Nodes.
   - Select the Geom panel, click surface edit, then select the trim with nodes option (on the far left side).
   - Press F11 on the keyboard to access the quick edit panel, then click on the first yellow node selector button to the right of “split surf-node:”.

2. Click on the Shaded Geometry and Surface Edges icon:

3. Trim lines are created by clicking on one line (or node on a line) and then clicking on another line (or node on a line). A trim line is then created between the two nodes.

4. Create trim lines by left-clicking on the following nodes:
   - 12 & 19,
   - 13 & 18,
   - 14 & 17,
   - 15 & 16,
   - 4 & 7,
   - 22 & 23,
   - 24 & 20,
   - 21 & 25,
   - 25 & 26

   The surface should now look like the one shown below:

5. Click return.
Step 14: Toggle the middle line in the left section of the component (to simulate a crack)

1. (If it is not still displayed, access the quick edit panel)
   • From the menu bar, choose Geometry > Edit > Surface Edges > Toggle.
   • Select the Geom panel, click edge edit, then select the toggle option (on the far left side).
   • Press F11 on the keyboard to access the quick edit panel, then click on the yellow line(s) selector button to the right of “toggle edge:”.
2. Make sure that the cleanup tolerance (“cleanup tol:” or “tolerance:”) is set to “0.01”.
3. Click on the Wireframe Geometry icon:
4. Right-click the line shown below:

   ![Diagram](image1)

The line should now be red. This causes the line to change from being a shared edge to being a free edge. The line should now look like the one shown below:

![Diagram](image2)

5. Click on the Shaded Geometry and Surface Edges icon:
6. Click return.
Step 15: Change the Meshing Options

1. Access the **Meshing Options** panel:
   - From the menu bar, choose **Preferences > Meshing Options**.
2. Make sure that the **mesh** option (on the left end of the panel) is selected.
3. For **node tol**, enter **0.01**
4. For **element size**, enter: **0.05**
5. Set the **feature angle** to **30**
6. Click **return**.

Step 16: Mesh the Left Side of the Component using 2D AutoMesh

1. Access the **2D AutoMesh** panel one of the following ways:
   - From the menu bar, choose **Mesh > Create > 2D AutoMesh**.
   - Press the **F12** key on the keyboard.
   - Select the **2D** panel and click on the **automesh** button.
2. With the selector button set to **surfs**, select the following parts of the surface shown below:
   (Left-click each one, or hold down the shift key on the keyboard while clicking and dragging the left mouse button to enclose the parts in a selection rectangle)

3. For **element size**, enter: **0.05**
4. For **mesh type**, click on the upside-down black triangle and select **quads only**.
5. Make sure that the settings are set to **elems to current comp, first order**, and **keep connectivity**.
6. On the bottom left corner of the panel, toggle the setting to be **interactive**.
7. Click **mesh**. (the green button on the upper right corner of the panel)
   *The message “1050 elements were created” should appear in the **status** bar.
8. On the left side of the panel, select the **biasing** option.
9. For **intensity**, enter: **3.00**
   *Note: even if the value for **intensity:** is already set to 3.00, you still need to click on the number “3.00” in the text box to the right of **intensity:** before you select a line to change
10. Left-click on the numbers shown below:

The edges should now display “3.000”

11. For intensity, enter: -3.00

12. Left-click on the numbers shown below:

13. Click mesh. (the green button on the upper right corner of the panel)

The mesh should now look like the one shown below:
Step 17: Mesh the Middle Section of the Surface

1. Click on the Wireframe Geometry icon:

2. Access the Ruled mesh panel one of the following ways:
   • From the menu bar, choose Mesh > Create > 2D Elements > Ruled
   • Select the 2D panel and click on the ruled button.

3. With the first (upper) “line list” yellow button selected, move the mouse cursor over the top edge of the circle (in the center of the part).

4. With the cursor near the top edge of the circle, hold down the left mouse button and slowly move the cursor down toward the center of the circle just enough so that the top edge of the circle is highlighted.

5. Let go of the left mouse button. The top edge of the circle should now be selected.
   *If at any time the complete circle is accidentally selected, click on the button to the right of the “line list” button in order to clear the selection:

6. Make sure that the yellow selector button is set to “line list” (not “node list”)

7. Click on the second (lower) “line list” yellow button. Left-click the left, top, and right sides of the rectangular section above the circle, shown below:

8. In the middle of the panel, make sure that the “mesh, w/o surf” option is selected (it may be necessary to click on the black downward triangle and select it from the list of options).

9. Make sure that the auto reverse option is checked.

10. Click create. A ruled mesh is now created, and the mesh density panel is displayed.

11. On the right side of the panel, to the right of “elem density =” and just below the green “set all to” button, enter in 60 for the edge element density.

12. Left-click the number displayed (“38”) on the top edge of the circle.

13. Click mesh. The edge element density on the top edge of the circle (as well as the total edge density along the left, top, and right edges of the rectangular middle section) is now set to 60.
14. On the left edge of the panel, select the **biasing** option.
15. In the middle of the panel, to the right of “*intensity* =” and just below the green “*recalc all*” button, enter 3.00 for the edge element density.
16. Click on the “0.000” number shown below:

![Image of mesh panel with biasing option selected](image)

17. The edge bias should now be set to **3.000** (toward the circle)
18. Click **mesh**. The mesh should now look like the image below:

![Image of mesh panel after meshing](image)

19. Click **return**. The **ruled** mesh panel is now displayed again.
20. Repeat this process for the lower half of the middle section (below the circle). After this is completed, the mesh should look like the image below:

![Meshed Arc Corner Sections](image)

**Step 18: Mesh the Arc Corner Sections using the Ruled Mesh tool**

1. If is not still selected, go to the *ruled* mesh panel again.
2. With the first (upper) *line list* button selected, left-click the top right arc edge, shown below:

![Select Top Right Arc Edge](image)

3. Click on the second (lower) *line list* button. Left-click the left and bottom edges of the rectangular section (the square-shaped section just below and left of the upper right arc), shown below:

![Select Left and Bottom Edges](image)
4. In the middle of the panel, make sure that the “mesh, w/o surf” option is selected.
5. Make sure that the auto reverse option is checked.
6. Click create. A ruled mesh is now created, and the mesh density panel is displayed.
7. On the right side of the panel, to the right of “elem density=” and just below the green “set all to” button, enter in 30 for the edge element density.
8. Left-click the number displayed (“19”) on the arc.
9. Click mesh. The edge element density on the arc (as well as the total edge density along the left and bottom edges of the square section) is now set to 30.
10. On the left edge of the panel, select the biasing panel.
11. In the middle of the panel, to the right of “intensity=” and just below the green “recalc all” button, enter in 3.00 for the edge element density.
12. Click on the “0.000” number shown below:

The edge bias should now be set to 3.000 (toward the arc)

13. Click mesh. The mesh should now look like the image below:
14. Click return. The ruled mesh panel is now displayed again.
15. Repeat this process for the bottom right square section (with the arc on the lower right corner). After this is completed, the mesh should look like the image below:

![Image](image.png)

16. Once this is completed, click return again to return to the home panel

**Step 19: Mesh the Remaining Square Section of the Component using 2D AutoMesh**

1. Click on the *Shaded Geometry and Surface Edges* icon:

2. Access the **2D AutoMesh** panel one of the following ways:
   - From the menu bar, choose *Mesh > Create > 2D AutoMesh*.
   - Press the **F12** key on the keyboard.
   - Select the **2D** panel and click on the **automesh** button.

3. With the selector button set to **surf**, left-click the following section shown below:

![Image](image.png)

4. For *element size*, enter: **0.05**
5. For **mesh type**, click on the upside down black triangle and select **quads only**.
6. On the bottom left corner of the panel, toggle the option **interactive**.
7. Click **mesh**. (the green button on the upper right corner of the panel)
   *The message “400 elements were created” should appear in the status bar.

8. On the left side of the panel, select the **biasing** option.
9. For **intensity**, enter: **3.00**
10. Left-click on the number shown below:

The edges should now display “3.00”

11. For **intensity**, enter: **-3.00**
12. Left-click on the number shown below:
13. Click mesh. (the green button on the upper right corner of the panel)

The mesh should now look like the one shown below:

![Image of mesh]

14. Click return. Click return again to return to the home panel.

**Step 20: Link Equivalent Nodes**

1. Access the Equivalence panel one of the following ways:
   - From the menu bar, choose Mesh > Check > Nodes > Equivalence.
   - Select the Tool panel and click on the edges button.
   - Press Shift+F3 on the keyboard.
2. Make sure that the “tolerance =“ is set to 0.01.
3. Set the selector button to “elems”.
4. Click on the yellow selector button (now labeled “elems”), then select the elements shown in the image below (hold down the shift key on the keyboard, hold the left mouse button and drag the cursor over the elements to form a selection rectangle over them, selecting them).
5. Click on the green “preview equivalence” button. The display should now look like the image shown below:

The message “121 nodes were found” should appear in the status bar.

6. Click on the green “equivalence” button.

The message “121 nodes were equivalenced” should appear in the status bar.

7. The mesh should now look like the one shown below:

8. Click return.
Step 21: Create two load collectors names *loads* and *constraints*

1. Access the *Create load collector* panel one of the following ways:
   - From the menu bar, choose **Collectors > Create > Load Collectors**.
   - Right click in the Model Browser and click **Create > Load Collector**.
2. For **name**, enter: **loads**.
3. Set **Card image**: to **none** if it is not already.
4. Select a color by clicking on the active color.
   *Make sure that the settings are the same as the ones shown below:

5. Click **Create** to create the load collector (called “loads”).
6. Repeat steps 1 – 5 and create another load collector called “constraints”.
7. (If it does not already closed, close the “Create Load Collector” dialog box by clicking **Cancel**)

Step 22: Apply constraints (OPTISTRUCT SPC) to the left edge of the plate.

1. Use the Model Browser to turn off the display of the loads applied to geometric entities.
   - Left-click the geometry display buttons in the Model Browser so the component display changes from this:

   ![Component display before](image1)

   To this:

   ![Component display after](image2)
2. Click on the **Wireframe Geometry** icon:

3. Use the menu bar to enter the **Constraints** panel by selecting **BCs > Create > Constraints**.

4. Go to the **create** subpanel, if not already selected.

5. Make sure that the entity selector button is set to **lines** (using the down arrow on the left side of the yellow highlighted button). Select the left edge of the plate by holding down the **shift** key on the keyboard, then holding the left mouse button and dragging the cursor over the line shown in the following image below:

6. Activate degrees of freedom (dof) 1 through 6 ("dof1", "dof2", "dof3", "dof4", "dof5", & "dof6" should be checked).

   *For an OptiStruct linear static analysis: dof 1, 2, and 3 represent *translations* in the global x-, y-, and z-directions respectively; dof 4, 5, and 6 represent *rotations* about the global x-, y- and z-axis, respectively*

7. Set **load types** = to **SPC**.

8. For **size** = enter **0.2**.

   *(The display size of the constraints is now set to 0.2).*

   *Make sure that the settings are the same as the ones shown below:*
9. Click **create** to create the constraints on the line. The constraint should now look similar to the one shown below:

![Constraint Diagram]

10. Activate the option, **label constraints**.
    A label is displayed for each constraint. The labels identify what dofs are assigned to the constraints.

11. Click **return** to exit to the main menu.

Step 23: Map the constraints (OPTISTRUCT SPC) on the geometry lines to the channel nodes associated to the lines.

1. Access the **Loads on geom** panel from the menu bar by selecting **BCs > Loads on Geometry**.
2. Select **loadcols >> constraints**.
3. Click **select** to complete the selection of load collectors.
4. Click **map loads**.
   A constraint is at each node associated to the geometry lines, as shown below:

![Constraint Map Diagram]

5. Click **return** to exit to the main menu.
Step 24: Prepare to create forces (OPTISTRUCT FORCE) on the bracket for the pressing load case

1. In the Model Browser, right-click on the loads load collector and select Make Current. The loads load collector is now the current load collector, and any loads created will be placed in this collector.

Step 25: Prepare forces (OPTISTRUCT FORCE) on the bracket for the load case

1. Use the Model Browser to turn on the display of the loads applied to geometric entities.
   - Left-click the geometry display buttons in the Model Browser so the component display changes from this:

```
<table>
<thead>
<tr>
<th>Entities</th>
<th>ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material (1)</td>
<td></td>
</tr>
<tr>
<td>Title (1)</td>
<td></td>
</tr>
<tr>
<td>Property (1)</td>
<td></td>
</tr>
<tr>
<td>Assembly Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Component (1)</td>
<td></td>
</tr>
<tr>
<td>Plate</td>
<td>1</td>
</tr>
<tr>
<td>Load Collector (2)</td>
<td></td>
</tr>
<tr>
<td>Loads</td>
<td>1</td>
</tr>
<tr>
<td>Constraints</td>
<td>2</td>
</tr>
</tbody>
</table>
```

To this:

```
<table>
<thead>
<tr>
<th>Entities</th>
<th>ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material (1)</td>
<td></td>
</tr>
<tr>
<td>Title (1)</td>
<td></td>
</tr>
<tr>
<td>Property (1)</td>
<td></td>
</tr>
<tr>
<td>Assembly Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Component (1)</td>
<td></td>
</tr>
<tr>
<td>Plate</td>
<td>1</td>
</tr>
<tr>
<td>Load Collector (2)</td>
<td></td>
</tr>
<tr>
<td>Loads</td>
<td>1</td>
</tr>
<tr>
<td>Constraints</td>
<td>2</td>
</tr>
</tbody>
</table>
```

2. Access the Forces panel through the menu bar by selecting BCs > Create > Forces.
3. Go to the create subpanel.
4. With the nodes selector active, hold down the shift key on the keyboard, then hold down the left mouse button, dragging the mouse cursor over the nodes shown below (forming a selection rectangle around all of the lines):
5. For magnitude =, enter 500.
6. Switch the direction selector from N1, N2, N3 to x-axis.
7. Set load types = to FORCE.
8. (If it is not already, set the top right button to “magnitude % = ”)
9. For “magnitude % =” specify 0.1. The display size of the force is decreased.
10. Click “create” to create the forces.
   The forces should look like the ones shown below:

![Image of forces]

11. Click return to exit to the main menu.

**Step 26: Define the load step for the pressing load case.**

1. Access the LoadSteps panel through the menu bar by selecting Setup > Create > LoadSteps.
2. For name =, enter “loading_step”.
3. Make sure that only the SPC and LOAD options are checked.
4. Click the "=" button to the right of “SPC”.
5. In the lower right corner, switch name to name(id).
   This shows the names of the load collectors with their ID numbers in parenthesis
6. Select the “constraints(2)” load collector.
   **Note:** The field next to the = now has a value of 2, which is the ID of the constraints load collector.
7. Click the = next to LOAD and select the “loads(1)” load collector.
8. Set the type: to linear static.
   *Make sure that the settings are the same as the ones shown below:

![Table of load settings]
9. Click create to create the load step, loading_step.
10. Click return to exit to the main menu.

**Step 27: Launch the OptiStruct job.**

1. Choose the Analysis page and select the OptiStruct panel.
2. Click “save as...”.
   A “Save file ...” browser window pops up
3. Select the directory where you would like to write the model file and enter the file name, plate.fem, in the “File name:” field.
   The .fem file name extension is the suggested extension for OptiStruct input decks.
4. Click Save.
   Note the name and location of the plate.fem file now displays in the input file: field.
5. Set the memory toggle, located in the center of the panel, to memory default.
6. Set the run options toggle, located on the left side of the panel, to analysis.
7. Set the export options: toggle, underneath the run options switch, to all.
8. Click OptiStruct.
   This exports the input file and launches the job. If the job is successful, new results files can be seen in the directory where the model file was written. The “plate.out” file is a good place to look for error messages that will help to debug the input deck if any errors are present.
   The default files written to your directory are:

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>plate.html</td>
<td>HTML report of the analysis, giving a summary of the problem formulation and the analysis results.</td>
</tr>
<tr>
<td>plate.out</td>
<td>ASCII output file containing specific information on the file set up, the set up of your optimization problem, estimate for the amount of RAM and disk space required for the run, information for each optimization iteration, and compute time information. Review this file for warnings and errors.</td>
</tr>
<tr>
<td>plate.res</td>
<td>HyperMesh binary results file.</td>
</tr>
<tr>
<td>plate.stat</td>
<td>Summary of analysis process, providing CPU information for each step during analysis process.</td>
</tr>
<tr>
<td>plate.h3d</td>
<td>HyperView binary result file.</td>
</tr>
</tbody>
</table>

The pop-up window should display “ANALYSIS COMPLETED” in the upper left text box and “==== Job completed ====” in the lower text box.
Step 28: Post-process the OptiStruct job

1. Open HyperView one of the following ways:
   - In the “HyperWorks Solver View” pop-up window, click on the “Results” button (to the left of “View” and the “Close” button) at the bottom-right corner of window.
   - Close the pop-up window. On the OptiStruct panel, click on the green “HyperView” button.

HyperView will open and automatically load the H3D file from the OptiStruct job for post-processing.

Step 29: View the results in HyperView

1. Make sure the view is in the standard XY view by clicking on the “XY Top Plane View” icon near the top of the HyperMesh window (right under the pull-down menus):
2. Click on the Contour button:

The Contour panel now appears.
3. Click on the highlighted yellow **Components** button, then select “All”.
4. Under **“Result type:”**, the two options for the first drop-down menu are:
   - Displacement (v)
   - Element Stresses (2D & 3D) (t)
5. Select “**Element Stresses (2D & 3D) (t)”**.
6. Select “**vonMises”** from the second drop-down menu.
7. Set the **“Averaging method:”** to be **Simple**.
8. Make sure that the **Contour** panel settings are the same as the settings in the image below:

   ![Contour Panel Settings](image)

9. Click **Apply**

The contour plot should look like the image below:

![Contour Plot](image)
Conclusion

1. Save the HyperView session one of the following ways:
   • From the menu bar, choose File > Save > Session.
   • Just below the menu bar, click on the Save Session button:


3. Save the HyperMesh file one of the following ways:
   • From the menu bar, choose File > Save.
   • Just below the menu bar, click on the Save Model button:


This completes the Finite Element Analysis of a Plate with Stress Concentrations Tutorial.